 What is SpywareGuard?

SpywareGuard is a real-time anti-spyware program.

An anti-virus program scans files before you open them and prevents execution if a virus is detected - SpywareGuard does the same thing, but for spyware! And you can easily have an anti-virus program running alongside SpywareGuard.

While there may be other programs that claim to protect your computer against spyware in real-time, there is a key difference between many of those programs and SpywareGuard:

  • SpywareGuard scans files BEFORE they are opened/run/executed, and can block access to the file (if spyware is detected) BEFORE it is run.

    Thus, if a spyware file is detected by SpywareGuard, it will not be opened or run at all.

    SpywareGuard also provides unique Download Protection (IE-only), which blocks spyware downloads, and Browser Hijack Protection, which alerts of browser hijacking activity in real-time.


 What is spyware?

Definition of spyware (quoted from spywareinfo.com):

"Spyware is software or hardware installed on a computer without the user's knowledge which gathers information about that user for later retrieval by whomever controls the spyware."

Generally, much so-called 'adware' can be considered a form of spyware.

In SpywareGuard, additional programs called 'browser hijackers' will be detected as spyware. These programs may install silently and, while many do gather information or perform tracking, some simply just 'hijack the browser' - or they change various browser settings and make them hard to change back. Some browser hijackers even embed themselves into your system and can cause a loss of internet connectivity if not removed correctly.

SpywareGuard may also detected some "premium-rate dialers". Many times, these dialers are installed without the user's knowledge (and even silently in the background by just viewing a webpage) and are not noticed until the month's phone bill shows a charge to some out-of-country number for hundreds of dollars.


SpywareGuard Real-Time Scanning

 Features: SpywareGuard Real-Time Scanning Engine

The SpywareGuard real-time scanning engine provides real-time protection against spyware. It scans .EXE and .CAB files before they are opened or executed.

To enable/disable protection, double-click on the red "SG" icon in the system tray.


SpywareGuard Download Protection

 Features: SpywareGuard Download Protection

SpywareGuard's Download Protection feature can block spyware from being downloaded in Internet Explorer. It is highly recommended that you keep this feature enabled, as it provides another important layer of protection.

To enable/disable protection (or change settings), double-click on the red "SG" icon in the system tray.


SpywareGuard Browser Hijacking Protection

 Features: SpywareGuard Browser Hijacking Protection

SpywareGuard now incorporates optional browser hijacking protection.

If you currently use Browser Hijack Blaster, it is recommended that you uninstall it and use SpywareGuard's built-in Browser Hijacking Protection, which provides greater protection.

The Browser Hijacking Protection component of SpywareGuard will alert as soon as browser hijacking activity is detected. If a BHO (Browser Helper Object) is added, or if various Internet Explorer settings are changed (the homepage, search page, etc.) an alert will immediately be displayed, and the user will be given the option to ignore the change, or to revert to the previous settings.

To enable/disable protection (or change settings), double-click on the red "SG" icon in the system tray.


Detection Log

 Features: Detection Log

SpywareGuard keeps a log file when spyware is detected or blocked. The real-time scanning engine, download protection, and browser hijack protection all write to the log, which can be accessed through the "Reports" section of SpywareGuard.

A detection by the real-time scanning engine, for example, should log the following information:

  • The type of file (EXE or CAB).
  • The time and date.
  • The user who attempted to open the file.
  • The full path to the file detected as spyware.
  • The name of the spyware detected in the file.
  • The action taken by the user (on the alert screen).

    This log file, "sglog.txt", is located in the same folder as SpywareGuard. If you would like to clear this log file, you can either delete the file, or clear it from within the SpywareGuard main interface.


 Support / Troubleshooting

SpywareGuard is provided as freeware, and as such no phone-based support is provided.

However, we do make an effort to answer or respond to questions/problems/comments/suggestions.

If you have a question, comment, suggestion, or problem, we ask that you post about it at the link below.
-The official SpywareGuard forum at www.wilderssecurity.com


About

 About SpywareGuard

SpywareGuard is provided as freeware. As such, no money is made from the use of this program.

A considerable amount of time and money is spent researching new spyware and updating the definitions. To help cover these costs, we rely on your kind donations. To help support this anti-spyware effort, please see the SpywareGuard donation information webpage at:
http://www.wilderssecurity.net/spywareguarddonate.html

SpywareGuard is Copyright (C) 2002-2003 Javacool Software LLC. All Rights Reserved.


SpywareGuard Control Panel

 Features: SpywareGuard Control Panel

The SpywareGuard Control Panel provides easy access to configuration settings.

It also provides one interface where detection reports can be viewed, and the SG updater can be started.

You can exit the SpywareGuard Control Panel, and the main protection will still be enabled (if already enabled). However, it is highly recommended you do not do so, because the SpywareGuard Control Panel provides some extra protection features.


 What is SpywareGuard?

SpywareGuard is a real-time anti-spyware program.

An anti-virus program scans files before you open them and prevents execution if a virus is detected - SpywareGuard does the same thing, but for spyware! And you can easily have an anti-virus program running alongside SpywareGuard.

While there may be other programs that claim to protect your computer against spyware in real-time, there is a key difference between many of those programs and SpywareGuard:

  • SpywareGuard scans files BEFORE they are opened/run/executed, and can block access to the file (if spyware is detected) BEFORE it is run.

    Thus, if a spyware file is detected by SpywareGuard, it will not be opened or run at all.